相关文章推荐

解决idea的web项目tomcat启动后无法加载index.jsp文件(404)问题
在这里插入图片描述
使用servlet是正常的,可以用以下解决方式

  1. 打开项目设置Project Structure
    在这里插入图片描述

  2. 点击进入Project Settings下的Facets界面

  3. 选择你的web项目

  4. 在右边的界面中下方找到Web Resource Directory

  5. 将该路径后边加上\WEB-INF,变成 “项目名称\src\main\webapp\WEB-INF”,更改项目入口
    在这里插入图片描述
    ![在这里插入图片描述](https://img-blog.csdnimg.cn/a529c15c64894553ac8b60ad0cb52197.png?x-oss-process=image/watermark,type_ZHJvaWRzYW5zZmFsbGJhY2s,shadow_50,text_Q1NETiBAbXVuYW5ncw==,size_18,color_FFFFFF,t_70,g_se,x_16
    改为\test01\src\main\webapp\WEB-INF

  6. 重启tomcat,问题解决

实在解决不了,建议清空artifacts , 删除tomcat 重新配置
可以参考 https://blog.csdn.net/munangs/article/details/120261733?spm=1001.2014.3001.5502
可解决大部分问题

实在不行建议重建protect,
希望对各位有所帮助

解决idea的web项目tomcat启动后无法加载index.jsp文件(404)问题使用servlet是正常的,可以用以下解决方式1.打开项目设置Project Settings2.点击进入Project Settings下边的Facets界面;3.选择你的web项目4.在右边的界面中下方找到Web Resource Directory5.将该路径后边加上\WEB-INF,变成 “项目名称\src\main\webapp\WEB-INF”,更改项目入口改为\test01\src\ma 在本地计算机上,运行命令: $ procurator-local --remote-host 127.0.0.1 --remote-port 8080 --local-port 1080 --password foobar 在远程计算机上,运行命令: $ procurator-server --remote-port 8080 --password foobar $ make clean && make test 类型 状态 报告 消息 请求 的 资源 [/chapter06/IndexServlet] 不可 用 描述 源 服务器 未能 找到 目标 资源 的 表示 或者是 不愿 公开 一个 已经 存在 的 资源 表示 。 Apache Tomcat /9.0.37 问题原因,浏览器不能直接访问Java文件 问题的 解决 方法 1、提交表单时遇到此问题 <form name = reg action=/login method=post> <meta charset=UTF-8> 账号:<input type=text name=usernam 消息 请求 的 资源 [] 不可 用 描述 源 服务器 未能 找到 目标 资源 的 表示 或者是 不愿 公开 一个 已经 存在 的 资源 表示 。 Apache Tomcat /8.5.70 问题 描述 : 在本地可以启动 tomcat ,用idea启动 tomcat 项目报错。 解决 方案: 打开 Tomcat 配置,看这里是不是配置有问题 最下面不能选中Build ,要选中下面那个点应用
报错:Error,关于运行localhost://8080/一直提示:“ 源 服务器 未能 找到 目标 资源 的 表示 或者是 不愿 公开 一个 已经 存在 的 资源 表示 。“的可能问题集合。
检查maven的依赖是否正确导入,发现没问题 检查项目的Artifacts ,WEB-INF目录下是否有class目录和lib目录,如果没有则新建 一个 lib文件夹,并+ 添加全部依赖,保存。 以上检查无误后,发现.
问题: 最近在学习 一个 ssm的项目,在配置好spring,springmvc以及web.xml之后,连接 tomcat 成功,但是执行静态网页返回 404 。 仔细检查配置文件,发现都没什么问题,网上搜到的 解决 方案有遇到WEB-INF的文件结构问题(比如web.xml没有在WEB-INF目录下,或者webapp直接在src下之类的),有遇到配置文件问题 加annotation-driven的,annotation注解帮我们注入一些内置bean。 有遇到加metadata-complete = “fa......
【JavaWEB/表单提交/ Tomcat 】报 404 ,显示“ 请求 资源 […/Servlet] 不可 用问题 废话不多说,直接上问题截图,我用的工具是eclipse。 如果你在学习web开发的过程中,尤其是在写表单提交类程序过程中 出现 了这个错误那么,这篇文章可以保证完美 解决 它。 我是用的servlet名字叫LoginServlet。一下内容完全围绕它展开、 一下是我遇到这个问题的排查步骤。请大家跟我一起一一检查。 1、首先检查代码,是否是报错的/爆红的,这里我不截图了。大家自行检查。 2、点开WEB-INF,点开we
HTTP 状态 404 - 未 找到 类型 状态 报告 消息 请求 的 资源 [/] 不可 用 描述 源 服务器 未能 找到 目标 资源 的 表示 或者是 不愿 公开 一个 已经 存在 的 资源 表示 。 Apache Tomcat /8.5.76 解决 办法 .将上面的HTML大写改为小写如下图即可: web.xml <?xml version="1.0" encoding="UTF-8"?> <web-app xmlns="http://xmlns.jcp.org/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee htt
当 Tomcat 更换 源 服务器 后,有时会遇到 未能 找到 目标 资源 的情况。这可能是因为新的 源 服务器 不包含所需的 资源 或者 资源 名称发生了变化。此时, Tomcat 会产生 一个 类似于“ 404 Not Found”的错误信息, 表示 请求 的 资源 不 存在 。另外,有些情况下,也可能是因为 源 服务器 管理者 不愿 公开 一个 已 存在 的 资源 表。这时, Tomcat 会拒绝 请求 并给出错误信息。 为避免这种情况的发生,更换 Tomcat 源 服务器 前,需确保新的 源 服务器 上所需的 资源 已经 全部迁移,并且 资源 名称没有发生变化。此外,如果 目标 资源 不希望 公开 ,可以考虑将其放置在防火墙内,只允许特定IP地址的用户进行访问。在处理这种情况时,同时需要确保 Tomcat 的配置文件中对 资源 的配置是正确的,尤其是 资源 的URL路径和文件名等信息。 总之,为了避免 Tomcat 更换 源 服务器 后 出现 无法 找到 资源 的情况,需要对 资源 进行充分的检查和迁移,以确保 资源 名称和路径等信息一致,并在必要时采取适当的安全措施。这样才能保证 Tomcat 正常运行,提供稳定的服务。
ORACLE连接驱动、及安装本地oracle jar包到maven仓库时报UnsupportedClassVersionError或NullPointerException解决方法、Ojdbc驱动平替 通过JAVA代码访问服务器上传文件 PLSQL Developer 14安装
 
推荐文章